WordPress 2.9 upgrade failure

I upgraded WordPress from 2.8.x to 2.9 this morning, the site works well, but when I go to the main Admin Dashboard I get this error:

Not well-formed (invalid token) at line 1, column 1

Very annoying really, but I can still view other pages, so it seems to be a problem with the actual dashboard page verse the database or some other problem.

Will update once the problem is solved.

(12 minutes later..) Hmm: It’s now working… not sure that anything changed.